After trying flashing compiled U-boot and openwrt kernel using SD-card image it is not possible to boot from eMMC anymore. I have tried several guides, no one fits properly, and this is situation the board is right now (see the pic). Seems like it starts with MMC2 (eMMC), and eMMC is having hardcoded link into the SD-card (MMC1 - MMC device 1). I can't get where it is - in the board's boot loader or something is in the U-boot compiled within the openwrt.

It still can boot from the SD-card with the image mentioned above flashed into it. I even can boot kernel from eMMC if I boot U-boot / SPL from the SD-card. But cold start from eMMC does not work.

If I erase eMMC boot partition 1 with dd board is bricked (nothing on the console after power on), but still boots if I put SD-card in.

If I put my compiled U-boot image into eMMC boot partition 1 is shows the picture below if no SD-card with image is inserted.

I have tried several U-boots made for Nanopi neo, with the same results.

Tried to dd pre-built armbian onto eMMC, did not help, same screen.

I have put eflasher friendlywrt .img into the SD-card, and system says the same and does not boot from SD-card.

Searched through the internet and see some people have similar problems, but there's no solution for my case.

Any ideas how to restore the operation from eMMC?

Image (14).jpg
Image (14).jpg (229.07 KiB) Viewed 1979 times

Here's the related topic in the openwrt forum.