Power & Source of Big Ideas


Moderators: chensy, FATechsupport


I have a R5S and I am struggling to use it on OpenBSD. I can boot it, but I need it to use the DeviceTree option on the System Table Selection under System Configuration. But even though I chose Devicetree and saving it using F10 and hitting "Y", when I boot the operating system it is using ACPI, what can be confirmed by a reboot and a new visit to the bios setup to see its ACPI only there. I tried using another sd card, saving and changing to the boot sd card for OpenBSD (a complete power cycle here), and tried also all on the same boot, no reboot and boot straight the operating system. Both gets me to ACPI only and this way I don't get the ethernet cards available.

I am here asking as other can boot from Devicetree mode and all ethernet are available, so the operating system is not the culprit so far.

Has anyone seen this? Any hints or advices?


Just to help new users, I had progress on the matter as to using new uefi images and choosing on OpenBSD boot console the dtb option by typing just dtb on it. Then it loaded dtb aware and all NICs were shown.


Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 2 guests